[VOTE] Drop JSP 1.2 support in 2.3.24

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Drop JSP 1.2 support in 2.3.24

Daniel Dekany
Yet another voting with lazy consensus... silence gives assent. 72
hours left.

I think we have to drop JSP 1.2 support in 2.3.24 because of legal
reasons. The jps-api 1.2 artifact can't be found in the Maven Central
Repo, and it can't be upload for legal reasons. This means that as far
as FreeMarker 2.3.x depends on it, it can't be built without
developers getting that jar themselves and putting it into the Ivy
cache or something. (It has worked so far because freemarker.org has
hosted it in its own Ivy repo, but doing such legally gray things
won't go anymore as we move the site to the ASF's infrastructure.)

JSP 1.2 was part of J2EE 1.3 (September 24, 2001), and was replaced by
JSP 2.0 in J2EE 1.4 (November 11, 2003). So hopefully not many users
will be hurt.

--
Thanks,
 Daniel Dekany


------------------------------------------------------------------------------
_______________________________________________
FreeMarker-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freemarker-devel
Lee
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Drop JSP 1.2 support in 2.3.24

Lee
+1 To drop JSP 1.2 support

On Mon, Sep 14, 2015 at 11:10 AM, Daniel Dekany <[hidden email]> wrote:
Yet another voting with lazy consensus... silence gives assent. 72
hours left.

I think we have to drop JSP 1.2 support in 2.3.24 because of legal
reasons. The jps-api 1.2 artifact can't be found in the Maven Central
Repo, and it can't be upload for legal reasons. This means that as far
as FreeMarker 2.3.x depends on it, it can't be built without
developers getting that jar themselves and putting it into the Ivy
cache or something. (It has worked so far because freemarker.org has
hosted it in its own Ivy repo, but doing such legally gray things
won't go anymore as we move the site to the ASF's infrastructure.)

JSP 1.2 was part of J2EE 1.3 (September 24, 2001), and was replaced by
JSP 2.0 in J2EE 1.4 (November 11, 2003). So hopefully not many users
will be hurt.

--
Thanks,
 Daniel Dekany


------------------------------------------------------------------------------
_______________________________________________
FreeMarker-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freemarker-devel


------------------------------------------------------------------------------

_______________________________________________
FreeMarker-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freemarker-devel
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Drop JSP 1.2 support in 2.3.24

Woonsan Ko-2
In reply to this post by Daniel Dekany
+1

Woonsan


On Mon, Sep 14, 2015 at 2:10 PM, Daniel Dekany <[hidden email]> wrote:

> Yet another voting with lazy consensus... silence gives assent. 72
> hours left.
>
> I think we have to drop JSP 1.2 support in 2.3.24 because of legal
> reasons. The jps-api 1.2 artifact can't be found in the Maven Central
> Repo, and it can't be upload for legal reasons. This means that as far
> as FreeMarker 2.3.x depends on it, it can't be built without
> developers getting that jar themselves and putting it into the Ivy
> cache or something. (It has worked so far because freemarker.org has
> hosted it in its own Ivy repo, but doing such legally gray things
> won't go anymore as we move the site to the ASF's infrastructure.)
>
> JSP 1.2 was part of J2EE 1.3 (September 24, 2001), and was replaced by
> JSP 2.0 in J2EE 1.4 (November 11, 2003). So hopefully not many users
> will be hurt.
>
> --
> Thanks,
>  Daniel Dekany
>

------------------------------------------------------------------------------
_______________________________________________
FreeMarker-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freemarker-devel
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Drop JSP 1.2 support in 2.3.24

Daniel Dekany
All right, JSP 1.2 support was removed then, with lazy voting. There
was no objection, and two +1-s outside of mine. (With this, the build
no longer depends on any artifacts hosted on freemarker.org's Ivy
repository.)


Tuesday, September 15, 2015, 10:21:37 PM, Woonsan Ko wrote:

> +1
>
> Woonsan
>
>
> On Mon, Sep 14, 2015 at 2:10 PM, Daniel Dekany <[hidden email]> wrote:
>> Yet another voting with lazy consensus... silence gives assent. 72
>> hours left.
>>
>> I think we have to drop JSP 1.2 support in 2.3.24 because of legal
>> reasons. The jps-api 1.2 artifact can't be found in the Maven Central
>> Repo, and it can't be upload for legal reasons. This means that as far
>> as FreeMarker 2.3.x depends on it, it can't be built without
>> developers getting that jar themselves and putting it into the Ivy
>> cache or something. (It has worked so far because freemarker.org has
>> hosted it in its own Ivy repo, but doing such legally gray things
>> won't go anymore as we move the site to the ASF's infrastructure.)
>>
>> JSP 1.2 was part of J2EE 1.3 (September 24, 2001), and was replaced by
>> JSP 2.0 in J2EE 1.4 (November 11, 2003). So hopefully not many users
>> will be hurt.
>>
>> --
>> Thanks,
>>  Daniel Dekany
>>
>

--
Thanks,
 Daniel Dekany


------------------------------------------------------------------------------
_______________________________________________
FreeMarker-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/freemarker-devel